Managed hosting door True

Bèta van IE8 krijgt ook spoed-patch

 

Het ernstige security-gat in Internet Explorer zit ook in de bèta’s van de aanstaande versie 8 van die webbrowser. Opvallend genoeg komt Microsoft ook met een patch voor die, officieel niet ondersteunde, proefversie.

Het nieuwste beveiligingsgat in Microsofts webbrowser Internet Explorer (IE) is niet alleen aanwezig in de versie die de leverancier nog ondersteunt. Naast IE 5.01, 6 en 7 zit het security-gat ook in de bèta's van versie 8.

Microsoft komt nu met een patch voor die proefversies van IE8. De ondersteuning voor bèta-software is meestal minder, of zelfs afwezig, in vergelijking met die voor reguliere (release-) software. Het bedrijf heeft al vantevoren aangekondigd met een spoed-patch te komen voor de huidige, officieel ondersteunde versies van zijn webprogramma. Die patch komt tussen de reguliere, maandelijkse patchrondes door.

Ontwikkelwerk

IE8 is al sinds begin 2006 in ontwikkeling en biedt diverse verbeteringen. Daaronder bevinden zich nieuwe functies, maar ook betere ondersteuning voor officiële webstandaarden. Microsoft heeft echter ook terugwaartse compatibiliteit ingebouwd met de eigen, afwijkende standaarden in voorgaande IE-versies.

Laatstgenoemde is in IE8 de standaardinstelling, dit om compatibiliteit te behouden met websites die zijn afgestemd op IE-eigen technieken en niet of minder op webstandaarden. Die instelling werkt in de bèta's van IE8 nog niet vlekkeloos. Webontwikkelaars hebben dan ook nog wat werk voor de boeg. Microsoft biedt daarvoor de zogenoemde IE8 readiness toolkit.

Begin 2009

De definitieve uitvoering van IE8 moet begin 2009 jaar op de markt komen. Die volgt kort na de geplande publieke release candidate (RC) in het eerste kwartaal van dat jaar. De tweede bèta van IE8 kwam eind augustus 2008 uit voor het algemene publiek. Eerder kregen ontwikkelaars al toegang tot proefversies van IE8.

Dit artikel is afkomstig van Computable.nl (https://www.computable.nl/artikel/2815035). © Jaarbeurs IT Media.

?


Lees meer over



Lees ook


 

Reacties

Ie8 terugwaards compatible? Alle pagina's - onder ie6/7 ontworpen - moesten opnieuw worden aangemaakt, want ze zagen er niet meer uit onder ie8. Zich aan standaarden houden is een bijna wetmatig vereiste, waaraan je alleen als grootste ontkomt. Maar nu zijn velen de klos die op ie's hebben vertrouwd. natuurlijk zijn we als webontwikkelaars ook zelf schuldig. het kost echter wel geld. wat volgt?

Vacatures

Stuur door

Stuur dit artikel door

Je naam ontbreekt
Je e-mailadres ontbreekt
De naam van de ontvanger ontbreekt
Het e-mailadres van de ontvanger ontbreekt

×
×