Managed hosting door True

Malware misbruikt open WordPad-lek

 

Het beveiligingsgat in WordPad dat Microsoft niet heeft gedicht in de Windows-patchronde van deze maand wordt nu actief gebruikt door malware. Microsoft waarschuwt dan ook dat beheerders maatregelen moeten nemen.

Makers van malware zijn snel ingesprongen op een nieuw beveiligingsgat in Windows. Het gaat om een fout in de tekstconversie van WordPad. Microsoft levert die basale tekstverwerker al jaren mee in zijn besturingssysteem. Het security-gat levert een buffer overflow op wanneer WordPad bijvoorbeeld een Word 97-bestand probeert te openen. Via de buffer overflow kan een kwaadwillende eigen code laten uitvoeren op doel-pc.

Gerichte aanvallen

Microsoft waarschuwt in een security-bulletin voor dit beveiligingsgat. Volgens de leverancier is er vooralsnog geen sprake van grootschalig misbruik, maar juist van gerichte aanvallen die dan ook in beperkte kring plaatsvinden.

De leverancier zegt het gat nu te onderzoeken, maar laat nog niet weten wanneer het met een patch komt. Dat kan middels een service pack (SP), de maandelijkse patchronde of een eerder verschijnende update, meldt Microsoft in het security-bulletin. Laatstgenoemde is een zogeheten out-of-cycle patch, die de Windows-producent alleen in uitzonderlijke gevallen uitbrengt.

De maandelijkse patchronde moet beheerders en bedrijven namelijk regelmaat bieden. In de praktijk biedt het ook malwaremakers regelmaat, waar zij handig misbruik van maken. De bug in de tekstconversie van WordPad is niet gedicht in de patchronde van deze maand, die nu net is geweest.

Windows kwetsbaar

Dit WordPad-gat is aanwezig en te misbruiken op diverse Windows-versies. Kwetsbaar zijn: Windows 2000 met SP4, Windows XP met SP2, en Windows Server 2003 met SP1 én 2. De nieuwste Windows-versies - XP met SP3, Vista en Windows Server 2008 - zijn niet kwetsbaar. Microsoft meldt dat de code met de fout niet aanwezig is in die Windows-versies.

Dit artikel is afkomstig van Computable.nl (https://www.computable.nl/artikel/2808360). © Jaarbeurs IT Media.

?


Lees meer over



Lees ook


 

Reacties

Iets is mij niet duidelijk na lezing van dit artikel.
Gesteld wordt dat Windows XP met SP2 kwetsbaar is, maar XP met SP3 niet. Als ik dat goed interpreteer heb je met Windows XP dus geen probleem: werk je nog met SP 2 installeer dan SP 3, werk je al met SP 3 dan is er so-wie-so geen probleem. Waar zit de fout in mijn redenering?

Wordpad die "bijvoorbeeld" een Word 97 bestand probeert te openen ? Wat is "bijvoorbeeld" ? Alleen niet-Wordpad bestanden ? Dan zijn problemen eenvoudig te voorkomen lijkt mij. Voor iets anders zou je Wordpad toch al niet gebruiken.

@Xela: Jij hebt het goed begrepen, wat is jou nou niet duidelijk dan??

@Leon: Alleen niet-Wordpad bestanden?
Ja, zoals bestanden die eigenlijk binair zijn (executable code) en de extentie ".doc" (Word 97) dragen (Rename .EXE .DOC), bijvoorbeeld!

"Dit WordPad-gat is aanwezig en te misbruiken op diverse Windows-versies. Kwetsbaar zijn: Windows 2000 met SP4"

Het Windows 2000 OS bestaat uit ca 35-38 miljoenen regels code,
http://www.microsoft-watch.com/content/operating_systems/windows_crown_jewels_leak_to_the_web.html
http://www.macobserver.com/article/2004/02/13.1.shtml
die niet allemaal grondig getest kunnen worden, voordat het spul de commerciele markt op gaat. Dus intern is ongeveer bekend hoeveel bugs er nog een OS zitten als het de markt op gaat.

Ik vraag me af hoeveel meer "known bugs" er aanwezig zijn in het Windows operating system...

Mhh heb dus XP-sp3 maar wel degelijk nog steeds open voor exploits al zijn dan wel sommige services nodig
indien die uit dan redelijk te zeggen ok het werkt
Maar waarom nou de achterklep steeds open gaat als ik toeter , Wee Nie

Waar kan ik wordpad vinden. Ik bijf maar zoeken en vind hem nergens. Waar hij zit is mij een raadsel.

Vacatures

Stuur door

Stuur dit artikel door

Je naam ontbreekt
Je e-mailadres ontbreekt
De naam van de ontvanger ontbreekt
Het e-mailadres van de ontvanger ontbreekt

×
×